Incident report
Incident Report for Universign
Postmortem

We are sorry for the inconvenience caused by the incident on 15/12/2022 between 3:31 p.m. and 3:55 p.m.

A temporary and outsized increase in demands on our application led to a significant performance degradation. The necessary steps were taken to restore the situation as quickly as possible.

Posted Dec 19, 2022 - 08:07 CET

Resolved
We are currently experiencing difficulties on our platform.

More information will be made available as it is conveyed to us.
Posted Dec 15, 2022 - 15:30 CET