Identified Major outage
Incident Report for Universign
Resolved
This incident has been resolved.

We are preparing a global report about this incident.

We deeply apologize for the inconvenience.
Posted Mar 18, 2024 - 19:26 CET
Update
We are continuing to monitor for any further issues.
Posted Mar 18, 2024 - 19:23 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2024 - 18:02 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 18:00 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 17:37 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 17:13 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 17:10 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 16:45 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 16:44 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 16:24 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 15:50 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 15:27 CET
Identified
We are facing a major outage.

The problem is identified and we are working on a fix right now.
Posted Mar 18, 2024 - 15:06 CET
Update
We are continuing to monitor for any further issues.
Posted Mar 18, 2024 - 14:19 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2024 - 13:45 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 13:12 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 12:39 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 12:09 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 18, 2024 - 11:47 CET
Identified
We are facing a minor outage.

The problem is identified and we are working on a fix right now.
Posted Mar 18, 2024 - 11:21 CET
This incident affected: Signature management API, Timestamp API, Seal API, Web Application, Signature Page, and Platform Availability.